HelpSpot 4.6.8

Recent Requirement Changes

  • HelpSpot now requires at least PHP 5.6 or PHP 7 
  • HelpSpot database requirements: MySQL based installations are now MySQL 5.6 or MariaDB 10.0.5

Improvements

  • Brought back database-based searching as SqlServer and MySQL both now more easily support and allow Full Text indexing setup programmatically. SphinxSearch can still be used, but may become depreciated.
  • Improved custom field “always visible” explanation text

Windows Installer

  • SqlServer drivers for PHP 7.0 updated to latest available version, resolves potential issue with connection problems
  • PHP fileinfo module added, resolving issue where some files had an incorrect mime type (file type) associated with them
  • Fixed issue where bundled mysql database name was assumed rather than retrieved dynamically
  • max_input_vars php.ini setting updated to allow for long requests, resolves issue where customer with large numbers of custom fields could not create new requests

Bug Fixes

  • Fixed issue with Outlook 2016 headers and parsing “reply above” text
  • Fixed bug in updating to version 4 where some HS_Settings items were not encoded to utf8
  • Fixed but in updating to version 4 where text-based custom fields were not encoded to utf8
  • Fixed issue where emailed changes to a request (staff notification) may not have included each change 
  • Fixed issue where staff notifications could fail on email-based request updates when required custom fields  were not filled in
  • Fixed issue where portal “Most Helpful Articles” returned incorrect book results
  • Fixed issue where grouping options were different in the requests over time report vs matrix report
  • Fixed issue where long field values needed to be truncated within the HS_Request_Events table, which tracks changes to a request over time
  • Fixed an issue where merges could delete a request erroneously
  • Fixed issue where the table of results action in a automation would send staff notifications and create request history items.